Supported .NET Framework

Jan 19, 2009 at 7:58 AM
Hi,
I have two legacy applications, one is using .NET Framework v1.1 and another is using v2.0. Will I be able use AntiXSS SRE with my existing sites? It seems that SRE has been developed using .NET Framework v3.5.

Feb 2, 2009 at 12:08 PM
Hi Probeer,

I am the PM for the Project, and while I would love to tell you yes - I just don't forsee us developing the SRE in a .NET Framework v1.1 or v2.0.
What I can say is that the source code is availible under the Microsoft Public License, so it is possible for you to make those changes for yourself.


Dennis
Coordinator
Feb 23, 2009 at 4:40 PM
Hi,

As dennis says we are not going to develop one specially for 1.1 but SRE is backward compatible with .NET 2.0. We have tested SRE with .NET 2.0 applications and it works as expected. In case of .NET 1.1 SRE will not work. SRE utilizes PostMapRequestHandler event of HttpApplication class which is not available in .NET 1.1.

Thanks
Anil RV